实例解决vue中使用lang=“scss“出现的报错

本篇文章给大家带来了关于vue的相关知识,其中主要介绍了关于使用 lang=“scss“ 报错的相关问题,这是因为当前sass-loader的版本太高,webpack编译时出现了错误,下面一起来看一下,希望对大家有帮助。vue 使用 lan

本篇文章给大家带来了关于vue的相关知识,其中主要介绍了关于使用 lang=“scss“ 报错的相关问题,这是因为当前sass-loader的版本太高,webpack编译时出现了错误,下面一起来看一下,希望对大家有帮助。

实例解决vue中使用lang=“scss“出现的报错

vue 使用 lang=“scss” 报错

在写VUE在线编辑器的时候,为了样式能够美观一些,在style中加入lang=“scss”,显示如下报错:

实例解决vue中使用lang=“scss“出现的报错

这是因为当前sass-loader的版本太高,webpack编译时出现了错误,所以我们安装低版本的

依次在项目中输入以下命令:

npm install sass-loader@7.3.1 --save-dev
npm install node-sass --save
npm install style-loader --save

这样在使用lang="scss"时就不会报错了

不能直接使用命令:

npm install sass-loader --save-dev

不然会报以下错误:

Module build failed: TypeError: this.getResolve is not a function at Object.loader

因为当前sass的版本太高,webpack编译时出现了错误,所以指定:npm install sass-loader@7.3.1 --save-dev 安装低版本的。

接下来,在build/webpack.base.config.js中添加:

{
    test: /\.scss$/,
    loaders: ['style', 'css', 'sass']
}

如图:

实例解决vue中使用lang=“scss“出现的报错

本站内容转自网络,若侵犯了你的权益,请联系我们,我们将在第一时间删除。

如若转载,请注明出处:http://www.ntuku.com/18266.html